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Introducing DBArtisan  

 

Introducing DBArtisan 
DBArtisan is an industry-leading database administration solution for managing Oracle, 
Microsoft SQL Server, Snowflake, Sybase, PostgreSQL, IBM DB2, and MySQL databases. Its 
cross- platform capability allows users to efficiently manage heterogeneous database 
platforms easily using a single front-end tool. Using DBArtisan, users boost their 
productivity by using a single tool for all their databases, regardless of the vendor. 

About DBArtisan 
Your new application provides tools that can be used by a number of functions within an 
organization using DBMS from multiple vendors, in testing, development, or production 
environments. 

Datasource and Server Management: Datasources must be registered. Datasources 
can be registered manually or semi-automatically. Storage can be registry-based or file- 
based, and a network storage option facilitates shared use of datasource catalogs. 

Object management tools: Your application supports a wide range of database 
objects and related elements for each DBMS. You can create new objects, edit existing 
objects, and use a range of object operations that support common, general or DBMS-
specific actions. 

Coding Environments/Editors: Fully-featured environments dedicated to SQL, DDL and 
Active Script development are provided. Execution options are available as appropriate, 
and environment-specific related features, such as rollback/commit and query plan 
options, are provided. Related coding aids include on-the-fly semantic and syntactic 
validation, text substitution shortcuts, and visual query building tools. Related execution 
tools include script and file execution facilities. 

Schema and data utilities (DBArtisan only): Schema extraction, migration, and 
publication wizards let you quickly extract and move schema and data across 
environments and even across DBMS types. DBMS-specific import/export, load/unload, 
and backup/restore utilities are also available. A Data Editor lets you edit your tables in 
real-time, supports all editable datatypes, and provides Unicode options. Table data can 
also be imported from formats such as spreadsheets. 

Project Management, Version Control, and Script Library: Database project 
management facilities help you organize, alter, and keep track of changes to database 
objects or SQL scripts. The project management facilities act as a repository to maintain 
all source code for a database project. DBArtisan also incorporates version control 
functions and build management facilities to help you manage and build projects. 

Other Time-savers and Productivity Tools: Working within the DBArtisan environment, 
you have access to database and file search facilities, use the visual difference to 
compare files or database objects, and access the Microsoft Windows task scheduler. 
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License-specific Add-ons: Depending on the licenses you purchased, you have access 
to the following tools: 

• The DBArtisan Analyst Series includes advanced space, capacity, performance 
and backup management capabilities. They let you predict and prevent storage- 
related problems, trend data and object growth over time, and pinpoint 
performance bottlenecks. 

• Debuggers, available for IBM DB2 for Linux, Unix, and Windows, Oracle, Sybase, 
and SQL Server, let you test functions and procedures. A Profiler is available for 
Oracle datasources. 

Technical Requirements 
For information on the technical requirements of DBArtisan, including supported 
operating systems and databases, see DB PowerStudio Technical Specifications. 

DBMS Support and Connectivity Options 
Dedicated Support Connectivity Options 
DBArtisan provides dedicated connectivity to a specific version range of IBM DB2 for Linux, 
UNIX, and Windows, IBM DB2 for z/OS, Microsoft SQL Server, MySQL, PostgreSQL, Oracle, 
Sybase, and Teradata databases. The following connectivity options are provided: 

• Native drivers: DBArtisan is packaged with a set of native drivers, each requiring a 
DBMS-specific client to be installed. 

• JDBC drivers: DBArtisan can connect to a datasource more directly using one of the 
packaged, third-party JDBC drivers. No additional connectivity components need to be 
installed. One or more third-party drivers, tested against DBArtisan, are installed with 
DBArtisan. 

The following table provides a summary of resources/requirements for connectivity to 
dedicated DBMS platforms. For each platform, it lists supported versions, the client software 
that must be installed if using native IDERA clients, and the third-party, Type 4 JDBC drivers 
packaged with DBArtisan. 

DBMS Platform Supported Version Client Required for 
Use with Native 
IDERA Drivers 

Packaged JDBC 
Driver 

Source & 
License 

Amazon 
Redshift 

    

IBM DB2 for 
z/OS 

10x and 11.x* DB2 UDB Client for 
Windows 8.0 or later 

 

IBM Data Server 
Driver for JDBC 

 

 

-- 

 

 

 

 

https://wiki.idera.com/display/TechSpecs/DB+PowerStudio+Technical+Specifications


IDERA, Inc. 7 

DBMS Support and Connectivity Options  

 

DBMS Platform Supported Version Client Required for 
Use with Native 
IDERA Drivers 

Packaged JDBC 
Driver 

Source & 
License 

IBM DB2 for LUW 10.x and 11.x* IBM DB2 LUW Client 
for Windows 8.0 or 
later 

IBM Data Server 
Driver for JDBC 

-- 

Microsoft SQL 
Server 

2008, 2012, 2014*, 
2016*, 2017*, 2019* 

Microsoft SQL Server 
client Library 

jTDS Type 4 JDBC 
Driver for Microsoft 
SQL Server 

Microsoft SQL 
Server JDBC Driver 

LGPL 
source, 
license 

Microsoft Azure 
SQL Database 

 Microsoft SQL Server 
client Library 

jTDS Type 4 JDBC 
Driver for Microsoft 
SQL Server 

Microsoft SQL 
Server JDBC Driver 

 

MySQL 4.x, 5.x*, and 8.x* MySQL 
Connector/ODBC 
Driver 5.2.x Driver – 
MySQL 
Connector/ODBC 
driver 3.51.x Driver 

MySQL 
Connector/J JDBC 
Driver 

GPL 
source, 
license 

Oracle 10g, 11g, 11g R2, 12c, 
12c R2*, 18c*, 19c* 

Oracle SQL*Net 
Client 

Oracle JDBC Thin - 
Driver 

-- 

PostgreSQL 9.3 - 9.10, 10.7, 11.2, 
12.x, 14.x  

Specifically-
supported 
PostgreSQL-based 
database products 
include Greenplum, 
Pivotal HAWQ, and 
BigSQL 

PostgreSQL ODBC 
Driver (latest version 
recommended) 

PostgreSQL JDBC 
Driver 

BSD license 

Snowflake  Snowflake ODBC 
Driver 

Snowflake JDBC 
Driver shipped with 
product 

 

Sybase ASE 15.7, 16.0 Sybase Open Client jTDS Type 4 JDBC 
Driver for Microsoft 
SQL Server  

Sybase jConnect 
JDBC Driver 

 

 

LGPL 
source, 
license 

http://sourceforge.net/projects/jtds/files/
http://jtds.sourceforge.net/license.html
http://dev.mysql.com/downloads/connector/j/
http://dev.mysql.com/downloads/connector/j/
https://jdbc.postgresql.org/about/license.html
https://docs.snowflake.com/en/user-guide/odbc-download.html
https://docs.snowflake.com/en/user-guide/odbc-download.html
https://docs.snowflake.com/en/user-guide/jdbc.html
https://docs.snowflake.com/en/user-guide/jdbc.html
https://docs.snowflake.com/en/user-guide/jdbc.html
http://sourceforge.net/projects/jtds/files/
http://jtds.sourceforge.net/license.html
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DBMS Platform Supported Version Client Required for 
Use with Native 
IDERA Drivers 

Packaged JDBC 
Driver 

Source & 
License 

Sybase IQ 15.4, 16.0, 16.1 SQL Anywhere ODBC 
Drivers for Sybase IQ 
12.7 

Sybase IQ 32-bit 
ODBC Drivers 

Sybase jConnect 
JDBC Driver for 
Sybase IQ 

-- 

* For these databases, DBArtisan supports a subset of this database version’s 
features/functions. 
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Generic JDBC/ODBC Connectivity 
Generic JDBC/ODBC connectivity to non-dedicated DBMS systems or non-database 
datasources is also provided. DBArtisan can connect to a datasource using a customer- 
provided, third-party JDBC version 4.0 or ODBC version 3.0 driver. Minimal DBArtisan 
functionality is provided, including a basic Explorer tree and SQL querying. 

IBM DB2 for Z/OS Stored Procedure Requirements 
When working against an IBM DB2 for z/OS data source, DBArtisan relies on the following 
stored procedures, provided as an optional installation step in setting up the DB2 
subsystem: 

• DSNWZP 

• DSNUTILS 

• ADMIN_COMMAND_DSN 

• ADMIN_COMMAND_DB2 

Prior to using DBArtisan against an IBM DB2 for z/OS data source, ensure that these 
components are installed on the server. 

Specifically-tested JDBC/ODBC Connectivity 
Products: Apache Hive/Hadoop 
DBArtisan has been successfully tested against Apache Hive/Hadoop datasources using 
the Hortonworks ODBC driver. Similarly, Cloudera Impala datasources have been tested 
using the Cloudera JDBC driver. In both cases, SQL querying and a Datasource 
Navigator/Explorer tree are available. 

DBMS Versions no Longer Supported 
DBArtisan is no longer being tested against Sybase ASE versions before 15.7. 

http://docwiki.embarcadero.com/DBArtisan/183/en/Using_the_Datasource_Explorer/Navigator
http://docwiki.embarcadero.com/DBArtisan/183/en/Using_the_Datasource_Explorer/Navigator
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Installing and Licensing DBArtisan 
Before you can register any IDERA application, you must meet the minimum technical 
requirements. If you meet all the minimum technical requirements, you can install 
DBArtisan. After installation, you must license the application. 

The following topics walk you through this process: 

• Installing DBArtisan 

• Licensing Your Product 

Installing DBArtisan 
To install the application successfully, you must complete each panel of the installation 
wizard. 64-bit and 32-bit versions of DBArtisan are available with the trial version, which 
can be downloaded from https://www.idera.com/dbartisan-database-administration-
solution. 

The DBArtisan installation wizard installs all corresponding files on your machine. The 
installer offers common options such as license agreement, file and folder selections, and 
shortcut options. An application-specific option lets you associate file suffixes of elements 
such as SQL scripts with DBArtisan. 

The panels presented by the wizard vary depending on whether you are upgrading or 
performing an initial installation. 

Caution: If you have not registered a license when you start a DBArtisan 
installation, you will be prompted to register a license. For more 
information, see Licensing Your Product. 

After the installation is complete, we recommend that you reboot your machine before 
using DBArtisan. 

Licensing Your Product 
Each IDERA client application requires one or more licenses to run. An IDERA product, 
such as DBArtisan, has a baseline license that provides basic feature support for that 
product. Also, incremental licenses may be required to support specific DBMS platforms, 
product add-ons, or other functions. 

For more information, see the following topics: 

• Licensing Overview 

• Licensing Your Application 

• Selecting a License Category During Startup 

• Online/Offline Mode and Concurrent License Checkout 

 

https://www.idera.com/dbartisan-database-administration-solution
https://www.idera.com/dbartisan-database-administration-solution
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Licensing Overview 
The following topics provide a high-level discussion of key licensing topics and directs you 
to sources of more detailed information. 

• Viewing Your License Type and Modules 
• Understanding Trial, Workstation, and Networked Licenses 
• DBArtisan License Modules, DBMS Support, and Feature Availability 
• Directing Queries Regarding Licenses 

Viewing Your License Type and Modules 
The About dialog in the Help menu, displays your license type and each license module 
currently registered. For the most current licensing information, check online help. 

Understanding Licenses 
Three kinds of licenses are available: Trial, Workstation, and Networked. 

• Trial licenses. A license for a 14-day, full-featured trial version of the product. The trial 
license must be registered before you can use the product. 

• Workstation licensing. A license or set of licenses is tied to a particular workstation. 
The product can be used only on that workstation. 

• Networked licensing. Networked licenses are administered and distributed by a 
central License Server (IDERA License Center or Acresso FLEXnet Publisher). There 
are two types of networked licenses: Concurrent and Networked Named User. With 
Concurrent licensing, users on different machines take turns using licenses from a 
shared pool. With Network Named User Licensing, licenses are pre-assigned to 
specific users set up on the license server’s user list. Those users are guaranteed to 
have licenses available any time. NOTE: Concurrent licenses can be borrowed for 
use without a network connection. For details, see Online/Offline Mode and 
Concurrent License Checkout. 

DBArtisan License Modules, DBMS Support, and 
Feature Availability 
Simplified licensing now offers a single DBArtisan license for single and multiplatform 
environments. Standard, Professional, and Workbench editions now are a single edition 
called DBArtisan, which also includes the previously optional Analyst Pack. Furthermore, 
the previously optional Analyst Pack now is included in DBArtisan.  

Directing Queries Regarding Licenses 
Direct questions regarding licenses, feature availability, and client or server licensing to: 

• If you work in an organization that uses networked licensing, direct any questions to 
your site’s DBArtisan administrator. 

• If you are using workstation licensing, direct licensing questions to your IDERA 
representative. 
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Licensing Your Application 
See the following topics for details on registering your product: 

• Registering a Trial or Workstation License during Installation 

• Registering a Workstation License After Application Startup 

• Registering By Phone 

• Registering a Networked License 

Registering a Trial or Workstation License during 
Installation 
Shortly after initiating the download of a trial version of an IDERA product, you should 
receive an email with a serial number you must register during installation. Similarly, if you 
purchase an IDERA product while no trial version is active, you will receive a serial 
number that must be registered during installation. 

1. Start the installation. An IDERA License Registration dialog appears. 

2. Copy the serial number from the email and paste it in the Serial Number field. 

3. Enter your EDN account credentials in the Login or Email and Password fields. If 
you have not previously created an EDN account or have forgotten your 
password, click I need to create ... or I’ve lost my password. 

4. Click Register. 
Your activation file should be downloaded and installed automatically. If this does 
not happen, click the Trouble Connecting? Try Web Registration link and follow 
the prompts. If you still have problems, see  Registering By Phone. 

Registering a Workstation License after Application 
Startup 
The following steps assume that you received a workstation license by email and that you 
have a valid trial license. If you did not install a trial version or the trial period has expired, 
follow the instructions in Registering a Trial or Workstation License during Installation. 

1. On the Help menu, select About, and then on the dialog that opens, click 
Manage to open a license manager dialog. 

2. On the Serial menu, select Add. 

3. Copy the serial number from the email and paste it in the Add Serial Number 
dialog, and then click OK. 

4. Right-click on the serial number you added, and then select Register from the 
context menu. A registration dialog opens. 

Note: The Registration Code box shows a machine-specific identifier required 
with other registration methods. 

5. Ensure that the Register using Online Registration radio box is selected. 
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6. Provide Developer Network credentials in the EDN Login name or Email and EDN 
Password boxes. If you have not previously created an EDN account or have 
forgotten your password, click I need to create ... or I’ve lost my password. 

7. Click Register. If prompted to restart the application, click Yes. 

Your activation file should be downloaded and installed automatically. If this does not 
happen, click the Trouble Connecting? Try Web Registration link and follow the 
prompts. If you still have problems,  Registering By Phone. 

Registering by Phone 
If you have problems with either of the above procedures, you can register licenses by 
phone. You will have to provide: 

• Developer Network credentials 

• The registration code displayed in the IDERA License Registration dialog that 
appears when you start an unlicensed application 

• The product base license serial number 

• The license serial numbers for any additional features you have purchased. 

For North America, Latin America, and Asia Pacific, call (415) 834-3131 option 2 and then 
follow the prompts. The hours are Monday through Friday, 6:00 A.M. to 6:00 P.M. Pacific 
time. 

For Europe, Africa, and the Middle East, call +44 (0)1628-684 494. The hours are Monday 
through Friday, 9 A.M. to 5:30 P.M. U.K. time. 

Shortly after phoning in, you will receive an email containing an activation file. Then do 
the following: 

1. Save the file to the desktop or a scratch directory such as c:\temp. 

2. On the Help menu select About and then on the dialog that opens, click 
Register. A registration dialog opens. 

3. Select the I have received an activation file (*.slip or reg*.txt) radio box. 

4. Click the Browse button and use the Select License Activation File dialog to 
locate and select the activation file you installed. 

5. Click the Import button to import the activation file and when complete, click the 
Finish button. 

6. If prompted to restart the application, click Yes. 

Registering a Networked License 
If you work in an organization using Networked licensing, an administrator, department 
head, or someone performing a similar function will provide you with an activation file. 

Once you receive the file, save it to the license subfolder of your product’s main 
installation folder (typically C:\Program Files\IDERA\<product><version>\license\), 
then restart the application. 

No additional steps are necessary. 
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Selecting a License Category a t  Startup 
During startup, if multiple concurrent license categories are available, you are prompted 
to select a category to use for this DBArtisan session. Multiple license categories can be 
set up to provide differing feature access or access to different DBMS versions. Feature 
and DBMS version access are typically distributed across multiple license categories to 
optimize the use of a site’s purchased licenses. 

Note: This dialog also includes the option to remember your selection on subsequent 
startups. If you select that option, you can subsequently use the Select Licenses 
button on the About... dialog (Help > About) to select a different license. 

Contact your License Administrator for details on individual license categories or requests 
for additional feature or DBMS support. 

Online/Offline Mode and Concurrent License 
Checkout 
Concurrent licenses can be used in both online and offline modes. In online mode, you 
must have a continuous network connection to your License Center. Licenses are 
checked out on startup and checked back in on shutdown. 

You can use a license in offline mode. When you explicitly check out a license for offline 
use, you can use the license without a connection to your License Center for a specified 
duration. This lets you work while travelling or commuting, work away from your primary 
work area, or use the license when a network connection is unavailable or not required. 

Note: Contact your site administrator for information on offline license availability, the 
maximum duration, offline license policy at your site, or any other issues arising 
from online license usage. 

To check out a license for offline use: 

1. On the Help menu, select Checkout License. The Check Out Licenses for Offline 
Use dialog opens. 

2. Select the check box associated with each license you want to check out. 

3. In the Checkout Duration box, type the number of hours that you can use the 
offline license without a network connection to the License Center. 

4. Click OK. You can work offline for the specified duration. The duration period 
begins immediately.  

If you subsequently establish a network connection to the License Center before the 
license duration expires, you can indicate to the License Center that the offline license is 
no longer required. 

To indicate that an offline license is no longer required: 

1. On the Help menu, select Checkin License. 

There is no interruption in DBArtisan usage. The license is not actually checked in 
until you shut down DBArtisan. 
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DBArtisan Tutorial exercises 
The exercises that follow walk you through DBArtisan’s major functional areas. After 
completing these exercises, you will have the foundation you need to explore the many 
features and benefits of DBArtisan. You’ll have learned how to competently manage the 
major database administration disciplines using DBArtisan’s standard cross-platform 
console. Also, you will have a solid understanding of DBArtisan’s more advanced Space, 
Performance, and Capacity management capabilities. 

This guide is divided into 10 sessions: 

• Session 1: Getting Started with DBArtisan 

• Session 2: Object and Schema Management 

• Session 3: Database Security Management 

• Session 4: Space Management 

• Session 5: SQL Management 

• Session 6: Job Management 

• Session 7: Data Management 

• Session 8: Performance Management 

• Session 9: Capacity Management 

• Session 10: General Utilities and Tools 

You can use this basic tutorial as a roadmap of product highlights, but also to help you 
find your own path to explore DBArtisan. 

Once you’ve started, you can select Help Topics from the Help menu to find many 
additional resources that complement and build on many of the activities shown in this 
tutorial. 
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Session 1: Getting Started with DBArtisan 
Your first tasks in getting familiar with DBArtisan are as follows: 

• Starting the DBArtisan Application 

• Registering Cross-Platform Datasources to DBArtisan 

• Setting up the Datasource Explorer 

• Exploring General Usability Features 

Starting the DBArtisan Application 
How you start DBArtisan depends on the type of application you are evaluating: 

• InstantOn version: start the application by double-clicking the file you 
downloaded. 

• Fully-installed version: The Start menu sequence for DBArtisan is always in the 
form Programs > IDERA DBArtisanversion identifier> DBArtisanversion identifier, 
where version identifier reflects the version you are running. 

To get started 

1. Run DBArtisan. 

The first time DBArtisan starts, a dialog opens, prompting you to set up 
datasources. In addition to letting you manually set up individual datasources, a 
number of more automated methods are available. If you have installed and 
used other IDERA tools, DBArtisan can find any active datasources being used by 
those tools. Also, DBArtisan provides a Discover Datasources feature that 
automatically searches the DBMS configuration files on your system for 
datasources that are not currently registered. Because other IDERA tools let you 
export datasource definitions to file, you also have the option of importing these 
definitions. 

2. For the purpose of this tutorial, click Cancel. You will be registering a datasource 
manually. 

Proceed to Registering Cross-Platform Datasources to DBArtisan. 

Registering Cross-Platform Datasources to DBArtisan 
The Datasource Registration Wizard walks you through the process of registering a 
datasource for use with DBArtisan. 

1. On the Datasource menu, select Register Datasource. DBArtisan opens the 
wizard, initially prompting you for the DBMS type. 

2. Select Oracle as the database type and then click Next. DBArtisan opens the 
next panel of the Datasource Registration Wizard. 
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3. Ensure that User defined is selected and provide the Host machine name 
associated with an Oracle datasource. 

4. Type a Port number. The default is 1521, but you can change it to wherever the 
Oracle listener is set up. 

5. Specify a Type of SERVICE_NAME or SID and enter the corresponding value in the 
SID/Service Name box. 

6. In the Datasource Name text box, type SAMPLE_DATASOURCE for the purpose of 
this example. 

7. Click Next. DBArtisan saves your selections and opens the next panel of the 
wizard. This is where you enter login credentials. 

8. Provide a User ID and Password. 

9. To save and encrypt your password so that you do not have to provide 
credentials each time you connect, select Auto-Connect? 

10. Click Datasource Group to display the last panel. 

11. In the Managed Datasources tree, select the folder corresponding to the type of 
DBMS you are registering. 

12. Click Finish. DBArtisan prompts you as to whether you want to connect to the 
datasource. Click Yes. 

The same easy-to-use Datasource Registration Wizard is available for directly-supported 
DBMS platforms as well as JDBC and ODBC datasources. Datasource information is 
stored in the registry, is editable, and datasources can be deleted. If you run multiple 
IDERA products on the same machine, they can share the same datasource catalog. 

A number of datasource catalog storage options are available: 

• A local, file-based alternative lets you move a datasource catalog between users. 

• A remote, file-based alternative lets multiple users share a single catalog. Settings 
can be changed locally but are not propagated to other users or retained over 
shutdown/startup 

For details on datasource options, refer to the DBArtisan online Help. Proceed to Setting 
up the Datasource Explorer. 
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Setting up the Datasource Explorer 
The first time you start DBArtisan, the Datasource Navigator occupies the left side of the 
main window. It is a single pane window that lets you navigate the datasources that you 
register and initiate actions against databases and database objects. 

 

For the following set of exercises, you will be using a similar aid. To prepare for 
subsequent exercises 

1. Dismiss the Navigator by clicking the close button (X) at the top of the Navigator 
window. 

2. Select View > Activate Explorer. 
The Datasource Explorer is a two pane window that provides most of the same 
functions as the Navigator. 
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One key difference is the right pane of the window. It displays details for the node 
currently selected in the left pane. This might be individual database objects such as 
tables or primary keys, configuration parameters, and so on. 

Before proceeding, familiarize yourself with the View menu commands for opening the 
Navigator and Explorer, and the ways to close those windows. As you proceed with 
DBArtisan, you will develop a preference for either the Navigator or Explorer, or find that 
each has benefits that are preferable in different situations. 

Proceed to Exploring General Usability Features. 

Exploring General Usability Features 
DBArtisan provides many “user in mind” features that make the product configurable to 
meet individual needs and preferences. These features are designed to shave time off 
the tasks that you perform many times on any given working day. 

Retaining Datasource Explorer View Settings 
1. At the top of the Explorer tree, click to expand the drop-down menu. 

 

2. Select Retain View Settings. 

The next time you open DBArtisan, the Explorer appears just as you left it.  

Working with Datasource Explorer Bookmarks 
1. In the Explorer tree, right-click the datasource you registered and select Add 

bookmark from the context menu. 
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DBArtisan opens the Add Friendly Bookmark Name dialog. 

2. Click OK. 

After Bookmarks are defined you can use them to easily navigate to commonly 
used datasource resources using the dropdown at the top of the Explorer and 
selecting the Bookmarks item. 

 

Setting Keyboard Shortcuts and Hotkeys 
1. From the Tools menu, select Customize. The Customize dialog opens. 

2. In the Customize dialog, open the Keyboard tab. 
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The Keyboard tab can be used to set keyboard shortcut hot keys for all areas of 
DBArtisan functionality. 

3. Click Close. 

Datasource Explorer tree filtering 
DBArtisan provides a number of ways to filter the Datasource Explorer tree, easing 
navigation. During a DBArtisan session, you can use the Filter box at the top of the 
Datasource Explorer to display only those objects whose name contains characters 
typed in the Filter box. 
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If you are interested in a more permanent filtering method, you can create filters at the 
DBMS or datasource level. Filters are available under the Filters node for each 
datasource. 

 

Right-clicking in the tree and selecting Filter opens the Filters dialog. It lets you filter out 
object types at the DBMS platform level. It also lets you create object filters. 

Object filters can be object name-based, schema-based, or some combination thereof. 
A name-based or schema-based filter consists of one or more ANDed conditions. You 
also specify the object types to which the filter is to apply. 

 

Object filters are created at the DBMS or datasource level and can be enabled and 
disabled for individual datasources. 
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The Filters dialog also lets you hide or display nodes based on object type. Node filtering 
lets you filter out object types for all datasources of the same DBMS type. 

 

In addition to any custom object filters you create, the Filters node also provides access 
to two default filters: Ignore System Objects and Show Only My Objects. They can be 
applied at the datasource level and cannot be deleted or modified. 

Proceed to Session 2: Object and Schema Management. 
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Session 2: Object and Schema 
Management 
DBArtisan provides unparalleled database object management capabilities. Its 
database platform-specific and version-specific graphical object editors and wizards 
enable you to easily create, drop or alter any of your accessible database objects. 

Creating a Table Object 
The following example walks you through creating a standard Oracle table object. This 
concept carries across all of the supported object types, across all of the supported 
platforms. 

1. On the Datasource Explorer, expand the Schema node of an Oracle datasource. 

2. Right-click the Tables node, and then select Create. 

3. DBArtisan opens the Table wizard and leads you through the process of creating a 
table object. 

 

4. Complete the wizard panels, and ensure that you create two or more columns in 
the table. 

5. Click Finish. 

DBArtisan lets you preview any and all generated scripts before you submit them to the 
database. This is standard for all object-related scripts. 
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Making changes to an existing table object 
Changes to database tables, such as modifying column lengths, inserting new columns, 
or deleting unneeded ones, can require dropping off a table. This requires knowledge of 
the underlying object dependencies so that these dependent objects are rebuilt after 
the table has been recreated. DBArtisan provides the ability to perform “extended” table 
alterations by constructing an SQL script with the steps necessary to save off the original 
data, create the new table, and populate it with the original data. Once these steps are 
complete, all dependent objects are then rebuilt and permissions re-applied. 

1. From the Explorer, Tables node, select the table you created in the previous 
example. 

2. Double-click the table or from the Command menu, click Open. 

DBArtisan opens the Table Editor. The Table Editor provides access to basic table 
properties, the list of table columns as well as any constraints, storage parameters, 
space allocation, partitioning, table dependencies, object privileges, table DDL 
and other attributes of the table. 

3. Ensure that the Columns tab is selected and select one of the columns you 
created in this table you want to modify. 

Details for the column are shown in the Column Attributes area on the right side 
of the pane. 

4. In the Width or Scale text box, type a new value. 

5. On the Table Editor toolbar, select the Alter button. 

DBArtisan lets you preview the SQL script before you submit it to the database. 

6. Close the Table Editor pane. 
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Working with Object DDL 
DBArtisan allows you to easily extract DDL for single or multiple objects using several 
methods. The most straight-forward is described here: 

1. On the Explorer, right-click the table you created earlier, and then select Extract. 
The DDL for all highlighted objects is extracted directly in a DDL Editor where it can 
be altered, executed and saved to the database, with no intermediary steps 
required. For example: 

 

2. Close the PL/SQL Editor pane. 

Proceed to Session 3: Database Security Management. 
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Session 3: Database Security Management 
DBArtisan can help you efficiently establish and maintain database security. Whether 
you are managing an existing production database or setting up a new environment, 
you’ll find consistent support across all of the supported platforms. 

Adding a new database user 
While this example focuses on creating a new Oracle user, the same wizard-driven 
principle applies to all security objects (groups, roles, etc.). 

1. On the Datasource Explorer, expand an Oracle datasource, and then the 
Security node. 

2. On the Security node, right-click Users, and then click Create. 

DBArtisan opens the Create User Wizard and leads you through the process of 
adding a user. 

 

3. Provide the information on each panel of the Create User Wizard until you reach 
the DDL View panel. 

DBArtisan allows you to preview any and all generated scripts before they are 
submitted to the database. This is standard for all object-related scripts. 

4. Click Execute to create the new user. 

DBArtisan automatically opens the User Editor for the new user. The standard User 
Editor can be used to manage existing database users as shown below. 
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Granting and Editing User Privileges 
Privileges can be easily granted, revoked, or viewed from within either of two editors 
within DBArtisan; the User Editor, or the individual object editor (Table, Procedure, etc.). 
The User Editor provides a tabbed interface, which can be used to view and modify 
individual attributes of the user. 

1. In the User Editor, open the Object Permissions tab. 

2. Use the Object Type dropdown to select a set of objects such as tables or views. 

3. Right-click a cell (corresponding to a specific object and a specific permission, 
such as DELETE), and then click Grant. 
A distinctive icon is shown in the cell, indicating that this permission is granted. You 
use a similar process to revoke privileges and perform other permission-based 
activities. 

4. On the Object Editor toolbar, click Alter to implement the changes.  

Proceed to Session 4: Space Management. 
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Session 4: Space Management 
Managing space is vital to ensure the availability and performance of your databases. 
DBArtisan incorporates many built-in space features that let you smartly manage and 
exploit all aspects of your database storage. The following examples walk you through a 
review of DBArtisan’s built-in support for reporting Oracle tablespace storage and space 
data. 

• Built-in Space Management 

• Advanced Space Management (Oracle and SQL Server only) 

Built-in Space Management 
While this example is specific to Oracle tablespaces, the same concept applies to all of 
the supported platforms. 

1. On the Datasource Explorer, expand any Oracle datasource. 

2. On the Oracle datasource, expand the Storage node, and then select 
Tablespaces. 

3. Right-click any tablespace listed in the right pane of the Explorer window, and 
then click Open. 

IDERA DBArtisan opens the Tablespaces Editor. 

4. Select the Properties tab. The Storage group on that tab provides a summary of 
the space settings for the tablespace. 

 

5. Select the Extent Details tab. It provides more detail on an extent-by-extent basis. 

 

6. On the Tablespace Editor, click the Space tab. 
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The Space tab displays a graphical view of the free and used blocks for the target 
tablespace. 

 

7. Finally, on the Tablespace Editor, click the Map tab. 

The Map tab displays a color-coded map of the objects contained on the 
tablespace. The map segments are proportional to the actual size of the objects 
on the tablespace. 

 

Note the additional Reorganize and display options. 

8. Close the Tablespaces Editor pane. 

Proceed to Advanced Space Management (Oracle and SQL Server only). 
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Advanced Space Management (Oracle and SQL 
Server only) 
For advanced space analysis and management, DBArtisan’s optional Space Analyst 
component contains sophisticated diagnostics to help you pinpoint all space-related 
problems in your database, as well as an intelligent reorganization wizard that can 
reorganize all or selected parts of your database. 

 

Note: Space Analyst is a separately-licensed component. If you are not working with an 
evaluation copy of DBArtisan or do not have a specific license, proceed to 
Session 5: SQL Management. Contact your license administrator or your IDERA 
representative about obtaining a license. 

To see the sort of information provided by the Space Analyst 

1. On the Analyst menu, select Space Analyst. 

Note: If prompted to install components on the server, allow DBArtisan to install 
the components. 

The Space Analyst launches in the DBArtisan workspace. 

IDERA Space Analyst provides sophisticated diagnostic capabilities to 
troubleshoot bottlenecks and performance inefficiencies that result in poor space 
management. See the DBArtisan online help for a detailed walkthrough of all 
available features and functionality. 

2. Select the Data Files, Tablespace Map, Tables, and Indexes tabs available at 
the bottom of the Space Analyst pane. 

3. Close the Space Analyst pane.  

Proceed to Session 5: SQL Management. 
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Session 5: SQL Management 
DBArtisan provides powerful visual tools for creating and analyzing complex SQL 
statements and server-side code objects. The following examples walk you through 
DBArtisan’s Visual Query Builder, feature-rich ISQL facility and some of the advanced 
analysis and debugging capabilities provided by the IDERA SQL Debugger and SQL 
Profiler: 

• Working with Query Builder 

• ISQL Window 

• SQL Debugging, Analysis and Tuning. 

Working with Query Builder 
1. From the Tools menu, select Query Builder. DBArtisan opens the Query Builder. 

2. In the Tables/Views tab, right-click a table or view and select Add. 

3. In the window that opens, select the columns to return the result. For example: 

 

Query Builder generates the query text in the lower SQL window. 
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You can build advanced queries using the options supplied on the DML tab. You 
choose the type of query (SELECT, INSERT, and so on) using the dropdown on the 
Query Builder toolbar. 

4. After the query is built, click the Execute button (green arrow) on the Query 
Builder toolbar. 

Query Builder displays results in the lower SQL window. 

5. Close the Query Builder pane. Proceed to ISQL Window. 

ISQL Window 
DBArtisan offers a fully-featured SQL editor. In addition to basic text processing features, 
the editor environment offers testing/debugging and execution facilities. In combination 
with supporting features, the ISQL editor eases and speeds up the process of developing 
working scripts. 

 

Automated error detection and coding assistance 
DBArtisan provides a range of features that detect or help you avoid errors and save 
keystrokes in developing your scripts. 

To enable these features: 

1. On the File menu select Options. The Options dialog opens. 

2. In the left-hand pane, expand the ISQL node and then select Code Assist. 
3. On the Code Assist panel: 

o Ensure that Enable Code Complete is selected. 

o Ensure that Enable Real-time syntax checking is selected. 

o Ensure that Severity levels for semantic validation problems has Warning 
selected. 

4. Click OK. 
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To see these features in action: 

1. On the File menu, select New > ISQL. 

DBArtisan opens the ISQL Editor window. You can add SQL code via your method 
of choice (free-form typing, retrieve from a file, paste copied code, etc.). 

2. Experiment with the automated error detection and coding assistance as follows: 

o Type SELECT * FROM and stop typing. Note the error condition. 

 

By default, DBArtisan runs a syntax check any time there is an interval of 1.5 
seconds between keystrokes. You can also disable automatic syntax 
checking and only run a check when you manually initiate it. Syntax error 
annotation persists until you correct the problem. 

o This time, type a fragment that includes the name of a nonexistent object, 
SELECT * FROM NON.OBJECT, for example. For now, ignore any popups. 
The warning condition is a result of on-the-fly semantic validation. DBArtisan 
notifies you when a script contains a reference to an object that DBArtisan 
cannot resolve. 

o Type SELECT * FROM followed by a space and then stop typing. If no 
popup appears, press CTRL+SPACE. The Code Complete suggestion box lets 
you select from objects or object name components such as databases or 
schema. This feature saves keystrokes and minimizes typing errors. See the 
online help for full descriptions of these features. 

3. If you want to disable the automated error detection and coding assistance 
features, select File > Options and on the Code Assist page, click Restore 
defaults. 

Feature Summary 
The ISQL Editor window includes the following features and options: 

• The ISQL window highlights all platform-specific and general keywords, and 
provides options for SQL code formatting and analysis. 

• Once the code is executed, you have control over whether your transaction is 
committed or rolled back from the database. 

• For all open ISQL windows, there are also options for connection locking, 
scheduling, executing your code across multiple datasources, explain plan 
generation, and SQL Tuning. 
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Setting environment options 
DBArtisan lets you set platform-specific query options to immediately determine if your 
code is optimized. 

1. Press F8. 

DBArtisan opens the Query Option dialog. 

 

2. Either close the Query Options dialog and then the SQL Editor window or enter a 
valid query in the ISQL editor and then execute your query by clicking the 
Execute button. 

 

3. When complete, ensure that only the Datasource Explorer window is open.  

Proceed to SQL Debugging, Analysis and Tuning. 

SQL Debugging, Analysis and Tuning 
While this example is specific to Oracle PL/SQL Debugging, the same interface and 
functionality applies to all of the supported platforms. 

To see debugging in action 

1. On the Datasource Explorer, expand any Oracle datasource node. 

2. On the Oracle datasource, select the Procedures node. 

3. In the right pane of the Explorer, right-click any stored procedure, and then select 
Debug. 

4. If prompted, enter any input parameters and then click Continue. 

After the SQL Debugger interface is displayed you can step through code, step 
into dependencies, set and watch variables, and even perform basic code 
profiling for each line of executed code. See the DBArtisan online help for a 
detailed listing of all available SQL features. 

5. Experiment with debugging features and then close the debugger window.  

Proceed to Session 6: Job Management. 
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Session 6: Job Management 
DBArtisan freely integrates with the Microsoft Windows Task Scheduler, which allows you 
to virtually schedule any task to run on your own computer whenever and how often 
you’d like. While this example is specific to an Oracle table redefinition, the same 
concept applies to any job or script that can be scheduled. 

To schedule a job, do the following: 

1. On the Explorer, expand any Oracle datasource. 

2. On the Oracle datasource, expand the Tables node, right-click any table, and 
select Extract. DBArtisan extracts the DDL that defines the selected table and 
opens an ISQL Editor window on the DDL. 

3. From the ISQL window toolbar, click the Schedule button.  

The Schedule Action dialog opens. You can provide a name, set notifications, 
and specify an output directory for the new job. 

 

4. After you have completed the dialog, click OK. The Job Scheduler dialog opens. 

5. Proceed as prompted to schedule your job. When finished, close the ISQL window. 

You can use the Oracle Job Queue explorer node to monitor your job. 
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Session 7: Data Management 
DBArtisan provides comprehensive facilities to help you manage the data in all of your 
databases. A visual data editor helps you add, change and delete data from your 
tables with all referential integrity enforced. You can create INSERT statements for tables 
using current data and also extract data as XML documents for certain databases. 
Rounding out its rich Schema Management capabilities, DBArtisan also allows you to 
migrate schema objects and associated table data from one database server to 
another, across the same or different platforms. 

The following topics walk you through some of the data management features: 

• Visual Data Editing 

• Working with Table Data - Create Insert Statements 

• Working with Table Data - Extract Data as XML 

• Advanced Data Management - Schema and Data Migration 

Visual Data Editing 
To start the Visual Data Editor, do the following: 

1. In the Datasource Explorer, right-click any table and select Edit Data. DBArtisan 
opens the Data Editor Filter dialog. 

2. In Columns, select the columns that are to be included in the editable data. 

 

You can also filter the editable rows by including your SELECT statement. 
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3. Click OK. 

In Live mode, all changes are applied to the database when you move off of an 
updated or inserted row. Deleted rows are immediately removed from the 
database. Batch mode allows you to make changes and then save all when all 
are complete. The mode is controlled by a dropdown in the Data Editor toolbar. 

4. Experiment with editing your data, and when complete, on the Data Editor 
toolbar, click the Execute (blue arrow) button. 

DBArtisan commits your changes. Regardless of mode, all of the generated DML 
statements are viewable in the lower SQL window. 

 

5. Close the Data Editor pane. 

Proceed to Working with Table Data - Create Insert Statements. 

Working with Table Data - Create Insert Statements 
DBArtisan lets you generate a set of INSERT statements based on rows of an existing 
table. 

1. On the Datasource Explorer, select any Oracle datasource. 

2. On the Oracle datasource, expand the Tables node. 

3. In the right pane of the Explorer window, right-click any table, and then select 
Create Insert Statements. DBArtisan opens the Create Insert Statements dialog. 
For example: 
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4. In Columns, select the columns you want to include in the INSERT statement. 

5. You can also filter what rows are included by adding your WHERE clause. 

6. Click OK. 

The resulting INSERT statements are created and presented in an active ISQL 
window. At this point, they can be executed immediately, scheduled to execute 
later, or saved. Note that all extracted INSERT statements can be run against the 
same or different databases containing a similar schema. 

 

7. Close the editor pane. 

Proceed to Working with Table Data - Extract Data as XML. 

Working with Table Data - Extract Data as XML 
DBArtisan lets you generate an XML representation of table data.  

To extract data as XML: 

1. On the Datasource Explorer, expand any Oracle datasource. 

2. On the Oracle datasource, expand the Tables node. 

3. In the right pane of the Explorer window, right-click any table listed, and then 
select Extract Data as XML. 

4. Select the columns to include in the SELECT statement. 

5. You can also filter what rows are included by adding a WHERE clause in the 
Select Statement box. 

6. Click OK. 

The resulting XML document is created and presented in an active XML Editor. At 
this point the document can be saved in XML format. 
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7. Close the editor pane. 

Proceed to Advanced Data Management - Schema and Data Migration. 

Advanced Data Management – Schema and Data 
Migration 
DBArtisan provides advanced data management tools that help you to move schema 
and corresponding table data across the same or different platforms. You can copy a 
single database object, all objects owned by a specific user, or an entire database, all 
guided by a wizard-driven process. 

While this example is specific to an Oracle to SQL Server schema and data migration, the 
same concept applies to any migration involving any combination of the supported 
platforms. 

To open the Schema Migration Wizard: 

1. On the Utilities menu, select Schema Migration. DBArtisan opens the Migration 
Wizard. 

2. Select the Perform new migration option. 

3. Click Next. DBArtisan opens the next panel of the Migration Wizard. For example: 
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4. Select an Oracle datasource from the Source Datasource list and a Microsoft SQL 
Server datasource from the Target Datasource list. 

5. Click Next and provide login credentials if prompted. DBArtisan opens the next 
panel of the Migration Wizard. 

Because Microsoft SQL Server supports multiple databases per datasource, you 
must choose a database. 

6. Select an entry from the Target Database list and then click Next. DBArtisan 
opens the next panel of the Migration Wizard. 
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7. In the Object Types list, select the object types to be migrated to the target 
datasource. 

As you select object types, the Objects list is updated to let you select specific 
objects to migrate. The Expand/Collapse icons let you drill down through 
dependencies/ containment. 

8. Use the Objects list to select the specific objects to migrate. 

9. Click Next. DBArtisan opens the next panel of the Migration Wizard. 
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10. Examine the migration options offered but leave the default settings for now. 

11. Click Next. DBArtisan opens the next panel of the Migration Wizard. Clicking Finish 
executes the migration and lets you view the progress of the job.  

Proceed to Session 8: Performance Management. 
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Session 8: Performance Management 
DBArtisan offers a number of different options to help you manage the performance of 
your databases. First, DBArtisan ships with a built-in process monitor that helps you 
understand who is connected to your database along with each user’s current activity 
and session-related data. For more robust performance details, DBArtisan’s Performance 
Analyst add-on is a powerful client-side database monitor that runs fully contained in the 
DBArtisan console. 

The following topics walk you through some of the performance management features: 

• Monitoring Sessions 

• Advanced Client-Side Performance Monitoring 

Monitoring Sessions 
While this example is specific to Oracle the Process Monitor is available for all of the 
supported platforms. 

To start the DBArtisan Process Monitor: 

1. On the Datasource Explorer, select any Oracle datasource. 

2. From the Utilities menu, select Database Monitor. 

 

The Database Monitor includes the following options and features: 

o Highlight any session and any currently running SQL is displayed in the lower 
pane. 

o You can drill-down into a specific session to display session-level statistical 
details, historical and current wait events along with a working copy of the 
currently running SQL that can be copied to an ISQL for Explain Plan 
generation. 

o By using the Monitor dropdown options you can display more advanced 
database-level monitoring data such as locks, blocking locks, hit ratio by 
user, Top 20 SQL, etc. 
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3. Close the Database Monitor pane. 

Proceed to Advanced Client-Side Performance Monitoring. 

Advanced Client-Side Performance Monitoring 
For advanced performance monitoring and management, DBArtisan’s optional 
Performance Analyst provides intelligent diagnostic information and strong drill-down 
details to help you get to the heart of any episode of performance degradation. 
Performance Analyst integrates completely with DBArtisan so that you can fix any 
performance problems with a few clicks of the mouse. 

Note: Performance Analyst is available for Oracle, SQL Server, Sybase ASE and DB2 for 
Unix, Windows, and Linux. 

Note: Performance Analyst is a separately-licensed component. If you are not working 
with an evaluation copy of DBArtisan or do not have a specific license, proceed 
to Session 10: General Utilities and Tools. Contact your license administrator or 
your IDERA representative about obtaining a license. 

1. On the Datasource Explorer, select any Oracle datasource. 

2. On the Analyst menu, select Performance Analyst. The Performance Analyst 
opens in the DBArtisan workspace for the target datasource. 

In addition to the Home page displayed initially, Performance Analyst presents 
several pages of statistics. Page categories include Memory, I/O, Space, 
Objects, Users, and OS. Each page contains several panes of related statistics, 
the Home page’s Key Ratio Analysis pane, for example: 
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Note the toolbar at the top of the Performance Analyst. It lets you navigate 
among the Performance Analyst statistics pages. 

 

3. Experiment with displaying the various pages available from the toolbar 
dropdowns. 

See the DBArtisan online help Performance Analyst topics for a detailed 
walkthrough of all available features and functionality. 

Proceed to Session 9: Capacity Management. 
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Session 9: Capacity Management 
Planning for the future of your critical databases used to be a difficult task. However, 
DBArtisan’s optional Capacity Analyst tool makes it easy to understand where your 
databases are today and where they are headed in the future. Capacity Analyst lets 
you track key database metadata and performance metrics over time so you can 
perform trend analysis on key areas like growth, object fragmentation, I/O and session 
load. Like all of the Analyst Series products, Capacity Analyst runs fully contained within 
DBArtisan so you have access to smart, built-in forecasting mechanisms that allow you to 
predict when your databases run out of space and the ability to proactively manage 
your storage assets, all from the same console. 

Performance Analyst is available for DB2 for Unix, Windows, and Linux, Sybase ASE, 
Oracle, and SQL Server. 

1. On the Datasource Explorer, select any Oracle datasource. 

2. From the Analyst menu, select Capacity Analyst. 

Note: Capacity Analyst is a separately-licensed component. If you are not 
working with an evaluation copy of DBArtisan or do not have a specific 
license, proceed to Session 10: General Utilities and Tools. Contact your 
license administrator or your IDERA representative about obtaining a 
license. 

The Capacity Analyst opens in the DBArtisan workspace for the target Oracle 
datasource. 

 

See the relevant DBArtisan online help topics for a detailed walkthrough of all available 
features and functionality. 

Proceed to Session 10: General Utilities and Tools. 
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Session 10: General Utilities and Tools 
No evaluation of DBArtisan would be complete without a mention of the general utilities 
and tools that are available across all of the supported platforms. The Utilities menu 
offers primarily DBMS-specific operations while those offered on the Tools menu are more 
generic. 

 

The Utilities menu contains the more advanced DBArtisan features. The available menu 
items are context-sensitive and version-specific for the selected datasource DBMS 
platform. This example above shows the Utilities menu features that are available for 
Oracle. 

The Tools menu contains those features that are common across all DBMS platforms. The 
example above shows the Tools menu features that are available for all supported DBMS 
platforms. Note that if any other IDERA products are installed on your client they will be 
available on the Tools menu. 

All DBArtisan utilities and tools provide a common interface that walks you through all 
input and execution requirements. All results are consistently presented so you can easily 
move between features without effort or confusion. 
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